vercel/PKGBUILD
Luzifer.io Jenkins fe1d07b30c vercel v37.4.0
2024-09-05 17:44:09 +00:00

36 lines
1.1 KiB
Bash

pkgname=vercel
pkgver=37.4.0
pkgrel=1
pkgdesc="The command line interface for Vercel"
arch=(any)
url="https://github.com/vercel/vercel"
license=('MIT')
depends=('npm')
makedepends=('jq')
source=(http://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz)
noextract=($pkgname-$pkgver.tgz)
sha256sums=('6594b1b5ac356e8076f79a2e8d2260a689d7fc7020c6911b541ccb4b394963c9')
# For more info about this package see:
# https://wiki.archlinux.org/index.php/Node.js_package_guidelines
package() {
npm install -g --cache "${srcdir}/npm-cache" --prefix "$pkgdir/usr" "$srcdir/$pkgname-$pkgver.tgz"
# Fix permissions
find "$pkgdir"/usr -type d -exec chmod 755 {} +
# Remove references to pkgdir
find "$pkgdir" -type f -name package.json -print0 | xargs -0 sed -i "/_where/d"
# Remove references to srcdir
local tmppackage="$(mktemp)"
local pkgjson="$pkgdir/usr/lib/node_modules/$pkgname/package.json"
jq '.|=with_entries(select(.key|test("_.+")|not))' "$pkgjson" > "$tmppackage"
mv "$tmppackage" "$pkgjson"
chmod 644 "$pkgjson"
# npm gives ownership of ALL FILES to build user
# https://bugs.archlinux.org/task/63396
chown -R root:root "${pkgdir}"
}