mirror of
https://github.com/luzifer-aur/beekeeper-studio-bin.git
synced 2024-12-20 06:41:18 +00:00
30 lines
1.5 KiB
Bash
30 lines
1.5 KiB
Bash
# Maintainer: Knut Ahlers <knut@ahlers.me>
|
|
# Contributor: Sitansh Rajput <me [at] lostpolaris [dot] com>
|
|
# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
|
|
# Contributor: Michael Lutonsky <m@luto.at>
|
|
# Contributor: Tássio Virgínio <tassiovirginio@gmail.com>
|
|
|
|
pkgname='beekeeper-studio-bin'
|
|
pkgver=5.0.9
|
|
pkgrel=1
|
|
pkgdesc='Modern and easy to use SQL client for MySQL, Postgres, SQLite, SQL Server, and more'
|
|
arch=('x86_64')
|
|
url='https://www.beekeeperstudio.io'
|
|
license=('MIT')
|
|
depends=('libappindicator-gtk3' 'libnotify' 'libsecret' 'libxss' 'libxslt' 'nodejs' 'nss' 'xdg-utils')
|
|
provides=(beekeeper-studio)
|
|
conflicts=(beekeeper-studio)
|
|
source=("beekeeper-studio-${pkgver}-license::https://github.com/beekeeper-studio/beekeeper-studio/raw/v${pkgver}/LICENSE.md"
|
|
"https://github.com/beekeeper-studio/beekeeper-studio/releases/download/v${pkgver}/beekeeper-studio_${pkgver}_amd64.deb")
|
|
sha256sums=('22b5a35031423ff3998ed524ff7464e071d25ad99fab5ce2ebb67158e62f7b17'
|
|
'437b42a7693ad17bcff27e0576479a66b4cfc7f1cb1b61424b88bf1e16323f48')
|
|
|
|
package() {
|
|
tar -xvf 'data.tar.xz' -C "${pkgdir}"
|
|
rm -rf "${pkgdir}/usr/share/doc"
|
|
install -dv "${pkgdir}/usr/bin"
|
|
ln -sfv "/opt/Beekeeper Studio/beekeeper-studio" -t "${pkgdir}/usr/bin"
|
|
install -Dvm644 "${pkgdir}/opt/Beekeeper Studio/"{'LICENSE.electron.txt','LICENSES.chromium.html'} \
|
|
-t "${pkgdir}/usr/share/licenses/beekeeper-studio"
|
|
install -Dvm644 "beekeeper-studio-${pkgver}-license" "${pkgdir}/usr/share/licenses/beekeeper-studio/LICENSE"
|
|
}
|